High temp on my Athlon II X4 620  

  RSS
Evire
(@evire)
Ninja

Hi there everybody!

I want to make this post because I need your help. I have a Athlon II X4 620 @ 3,18ghz running stock cooler and a HAF 932 case.

My bios settings are:
CPU buss frequency: 245
CPU ration: 13.00x
CPU Voltage: 1.3500

Problem is that it runs at 47C at idle... I though this CPU would be cooler, especially with my HAF 932. And yes, I just cleaned the case, so there are no dust inside.

EDIT: Just set it to normal @2,6ghz. Running 45C idle...

ReplyQuote
Posted : 27/12/2010 2:17 pm
Evire
(@evire)
Ninja

Maybe it is the thermal compound?
I did not apply any at my first assembly because there where compound on the cooler.
But I do got some Noctua NT-H1 Premium grade thermal compound laying around.

ReplyQuote
Posted : 27/12/2010 2:28 pm
Spaiker
(@spaiker)
Ninja

Thermal compound only drops the temps by a few degrees, so unless you had really bad one (like stock) this can be the issue. I have, however heard of some guys that that cpu runs hot on stock cooler. they bought an aftermarket cooler, and the temps dropped very hard. Maybe that would be a better idea if you have a spare 25$/€.

ReplyQuote
Posted : 27/12/2010 3:44 pm
Jester
(@jester)
Member Moderator

@Spaiker 53330 wrote:

Thermal compound only drops the temps by a few degrees, so unless you had really bad one (like stock) this can be the issue. I have, however heard of some guys that that cpu runs hot on stock cooler. they bought an aftermarket cooler, and the temps dropped very hard. Maybe that would be a better idea if you have a spare 25$/€.

Paste application has more of an effect on temperatures than the type of paste used. Unfortunately, my knowledge of AMD is very limited so for all I know your temps might be normal.

ReplyQuote
Posted : 27/12/2010 3:52 pm
Share:
  
Working

Please Login or Register